Help with command line (Mac OS terminal)

Anyone out there familiar with working in terminal specifically installing and running some scripts with python

I am very inexperienced using terminal and am getting some errors I do not know how to resolve

Anyone with slightly more basic knowledge than I could probably help. Not sure I am running commands in the right directory or if I have some supporting pieces installed in The right place. Also maybe need to change some permissions but not sure.

A quick screensahare would really help me out. Your efforts will be rewarded with some fun NFTs

This is the tutorial I am trying to follow along with.

https://medium.com/scrappy-squirrels/tutorial-create-generative-nft-art-with-rarities-8ee6ce843133

Hi there Casey! I’d be happy to help! I’m usually available in the afternoons and could gladly set up a screen share to take a look and tinker around with your settings a bit to figure this out.
Let me know a good time you’re available to crunch through these errors.

~ JJ

I would be happy to help!

The process looks like it is pretty easy. The biggest stumbling block for that I would think would be that you don’t have pip installed. Make sure you have both python and pip.

The installation for pip isn’t the most friendly but you first have to download pip from https://bootstrap.pypa.io/get-pip.py and go into the command line to wherever it is downloaded (probably the downloads directory) and run python get-pip.py. That should get it for you.

You should be able to verify that it works by running python --version and pip --version and having it tell you the installed programs version respectively.

That should get you to run the first command in the tutorial without problems pip install Pillow pandas progressbar2

If you are still having issues after trying that feel free to reach out again and I’d be happy to do a screen share with you. Best of luck with some NFTs! :grin:

JJ could you shoot me an email at [email protected] would love to screen share at any-point this afternoon.

I will give this a go. Thanks.

Heres two screenshots. I ran the pip --version in the folder where i have python installed.


and confirmed i have pip installed

then when i go to run python nft.py in the generative-art-nft folder as shown in the below screenshot i get the error also shown in the screenshot

Traceback (most recent call last):
File “nft.py”, line 5, in
from PIL import Image
ImportError: No module named PIL
[email protected]Mac generative-art-nft-master %

This may be the issue https://itsmycode.com/python-importerror-no-module-named-pil-solution/#:~:text=If%20you%20use%20the%20Python,library%20to%20resolve%20the%20issue..

One of the dependencies PIL seems like it was depreciated in favor of pillow

Assuming you are using a Mac, try

pip uninstall PIL
python3 -m pip install --upgrade pip
python3 -m pip install --upgrade Pillow

Thanks. Solution from discord was to run the following.

python3 nft.py

I have it working now which is super cool If you both send me either a ploygon/matic wallet address or email i’ll send you some NFTs when they are ready! Which will help me test my deployment via email pice too.

Glad to hear it worked! [email protected] if you have a few to send still :slight_smile: